<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://geoffboeing.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="http://geoffboeing.com/wp-content/themes/twentyfifteen/js/html5.js"></script>
	<![endif]-->
	<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Square-Mile Street Network Visualization - Geoff Boeing</title>

<!-- This site is optimized with the Yoast SEO plugin v4.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Square-mile street network visualizations of urban form created with Python, OSMnx and OpenStreetMap for any city in the world: history, design, walkability"/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Square-Mile Street Network Visualization - Geoff Boeing" />
<meta property="og:description" content="Square-mile street network visualizations of urban form created with Python, OSMnx and OpenStreetMap for any city in the world: history, design, walkability" />
<meta property="og:url" content="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/" />
<meta property="og:site_name" content="Geoff Boeing" />
<meta property="article:publisher" content="https://www.facebook.com/gboeing" />
<meta property="article:tag" content="boston" />
<meta property="article:tag" content="city" />
<meta property="article:tag" content="complex systems" />
<meta property="article:tag" content="complexity" />
<meta property="article:tag" content="data" />
<meta property="article:tag" content="data science" />
<meta property="article:tag" content="design" />
<meta property="article:tag" content="dubai" />
<meta property="article:tag" content="europe" />
<meta property="article:tag" content="geopandas" />
<meta property="article:tag" content="geopy" />
<meta property="article:tag" content="geospatial" />
<meta property="article:tag" content="gis" />
<meta property="article:tag" content="irvine" />
<meta property="article:tag" content="land use" />
<meta property="article:tag" content="livability" />
<meta property="article:tag" content="maps" />
<meta property="article:tag" content="matplotlib" />
<meta property="article:tag" content="modeling" />
<meta property="article:tag" content="neighborhood" />
<meta property="article:tag" content="networks" />
<meta property="article:tag" content="numpy" />
<meta property="article:tag" content="osaka" />
<meta property="article:tag" content="osmnx" />
<meta property="article:tag" content="pandas" />
<meta property="article:tag" content="portland" />
<meta property="article:tag" content="projection" />
<meta property="article:tag" content="python" />
<meta property="article:tag" content="rome" />
<meta property="article:tag" content="sacramento" />
<meta property="article:tag" content="san francisco" />
<meta property="article:tag" content="shapely" />
<meta property="article:tag" content="street-network" />
<meta property="article:tag" content="tutorial" />
<meta property="article:tag" content="urban" />
<meta property="article:tag" content="urban design" />
<meta property="article:tag" content="urban form" />
<meta property="article:tag" content="urban planning" />
<meta property="article:tag" content="visualization" />
<meta property="article:section" content="Planning" />
<meta property="article:published_time" content="2017-01-02T12:28:02-08:00" />
<meta property="article:modified_time" content="2017-01-25T09:27:43-08:00" />
<meta property="og:updated_time" content="2017-01-25T09:27:43-08:00" />
<meta property="fb:admins" content="10011515" />
<meta property="og:image" content="http://geoffboeing.com/wp-content/uploads/2016/11/gs_portland_san_francisco_irvine_rome-970x1024.jpg" />
<meta property="og:image" content="http://geoffboeing.com/wp-content/uploads/2017/01/gs_new_york_paris_tunis_atlanta-970x1024.jpg" />
<meta property="og:image" content="http://geoffboeing.com/wp-content/uploads/2017/01/gs_boston_dubai_sacramento_osaka-970x1024.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Square-mile street network visualizations of urban form created with Python, OSMnx and OpenStreetMap for any city in the world: history, design, walkability" />
<meta name="twitter:title" content="Square-Mile Street Network Visualization - Geoff Boeing" />
<meta name="twitter:site" content="@gboeing" />
<meta name="twitter:image" content="http://geoffboeing.com/wp-content/uploads/2016/11/gs_portland_san_francisco_irvine_rome-970x1024.jpg" />
<meta name="twitter:creator" content="@gboeing" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Geoff Boeing &raquo; Feed" href="http://geoffboeing.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Geoff Boeing &raquo; Comments Feed" href="http://geoffboeing.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Geoff Boeing &raquo; Square-Mile Street Network Visualization Comments Feed" href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/geoffboeing.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='twentyfifteen-jetpack-css'  href='http://geoffboeing.com/wp-content/plugins/jetpack/modules/theme-tools/compat/twentyfifteen.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfifteen-fonts-css'  href='https://fonts.googleapis.com/css?family=Noto+Sans%3A400italic%2C700italic%2C400%2C700%7CNoto+Serif%3A400italic%2C700italic%2C400%2C700%7CInconsolata%3A400%2C700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://geoffboeing.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfifteen-style-css'  href='http://geoffboeing.com/wp-content/themes/twentyfifteen/style.css?ver=4.7.2' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfifteen-ie-css'  href='http://geoffboeing.com/wp-content/themes/twentyfifteen/css/ie.css?ver=20141010' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='twentyfifteen-ie7-css'  href='http://geoffboeing.com/wp-content/themes/twentyfifteen/css/ie7.css?ver=20141010' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='social-logos-css'  href='http://geoffboeing.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://geoffboeing.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.6' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v5.5.4 - Universal disabled - https://www.monsterinsights.com/ -->
<script type="text/javascript">

	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-5213624-4']);
	_gaq.push(['_gat._forceSSL']);
	_gaq.push(['_trackPageview']);

	(function () {
		var ga = document.createElement('script');
		ga.type = 'text/javascript';
		ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0];
		s.parentNode.insertBefore(ga, s);
	})();

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://geoffboeing.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://geoffboeing.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://geoffboeing.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://geoffboeing.com/xmlrpc.php?rsd" />
<meta name="generator" content="WordPress 4.7.2" />
<link rel='shortlink' href='http://wp.me/pFgJa-Cv' />
<link rel="alternate" type="application/json+oembed" href="http://geoffboeing.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgeoffboeing.com%2F2017%2F01%2Fsquare-mile-street-network-visualization%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://geoffboeing.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgeoffboeing.com%2F2017%2F01%2Fsquare-mile-street-network-visualization%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css" id="syntaxhighlighteranchor"></style>
</head>

<body class="post-template-default single single-post postid-2387 single-format-standard">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<div id="sidebar" class="sidebar">
		<header id="masthead" class="site-header" role="banner">
			<div class="site-branding">
										<p class="site-title"><a href="http://geoffboeing.com/" rel="home">Geoff Boeing</a></p>
											<p class="site-description">PhD candidate, urban planning at UC Berkeley</p>
									<button class="secondary-toggle">Menu and widgets</button>
			</div><!-- .site-branding -->
		</header><!-- .site-header -->

			<div id="secondary" class="secondary">

					<nav id="site-navigation" class="main-navigation" role="navigation">
				<div class="menu-top-level-pages-container"><ul id="menu-top-level-pages" class="nav-menu"><li id="menu-item-1732" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1732"><a href="http://geoffboeing.com/">Home</a></li>
<li id="menu-item-1697" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1697"><a href="http://geoffboeing.com/about/">About</a></li>
<li id="menu-item-1695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1695"><a href="http://geoffboeing.com/publications/">Publications</a></li>
<li id="menu-item-2264" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2264"><a href="http://geoffboeing.com/press/">Press</a></li>
<li id="menu-item-1696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1696"><a href="http://geoffboeing.com/contact/">Contact</a></li>
</ul></div>			</nav><!-- .main-navigation -->
		
		
					<div id="widget-area" class="widget-area" role="complementary">
				<aside id="lsi_widget-3" class="widget widget_lsi_widget"><ul class="lsi-social-icons icon-set-lsi_widget-3" style="text-align: left"><li class="lsi-social-twitter"><a class="tooltip" rel="nofollow" title="Twitter" aria-label="Twitter" href="https://twitter.com/gboeing" ><i class="lsicon lsicon-twitter"></i></a></li><li class="lsi-social-linkedin"><a class="tooltip" rel="nofollow" title="LinkedIn" aria-label="LinkedIn" href="https://www.linkedin.com/in/gboeing" ><i class="lsicon lsicon-linkedin"></i></a></li><li class="lsi-social-github"><a class="tooltip" rel="nofollow" title="Github" aria-label="Github" href="https://github.com/gboeing" ><i class="lsicon lsicon-github"></i></a></li><li class="lsi-social-rss"><a class="tooltip" rel="nofollow" title="RSS" aria-label="RSS" href="http://geoffboeing.com/feed/" ><i class="lsicon lsicon-rss"></i></a></li></ul></aside>		<aside id="recent-posts-2" class="widget widget_recent_entries">		<h2 class="widget-title">Recent Posts</h2>		<ul>
					<li>
				<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/">Square-Mile Street Network Visualization</a>
						</li>
					<li>
				<a href="http://geoffboeing.com/2016/12/animating-lorenz-attractor-python/">Animating the Lorenz Attractor with Python</a>
						</li>
					<li>
				<a href="http://geoffboeing.com/2016/11/osmnx-python-street-networks/">OSMnx: Python for Street Networks</a>
						</li>
					<li>
				<a href="http://geoffboeing.com/2016/10/r-tree-spatial-index-python/">R-tree Spatial Indexing with Python</a>
						</li>
					<li>
				<a href="http://geoffboeing.com/2016/09/college-football-stadium-attendance/">College Football Stadium Attendance</a>
						</li>
				</ul>
		</aside>		<aside id="search-2" class="widget widget_search"><h2 class="widget-title">Search</h2><form role="search" method="get" class="search-form" action="http://geoffboeing.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit screen-reader-text" value="Search" />
			</form></aside><aside id="archives-2" class="widget widget_archive"><h2 class="widget-title">Archives</h2>		<ul>
			<li><a href='http://geoffboeing.com/2017/01/'>January 2017</a></li>
	<li><a href='http://geoffboeing.com/2016/12/'>December 2016</a></li>
	<li><a href='http://geoffboeing.com/2016/11/'>November 2016</a></li>
	<li><a href='http://geoffboeing.com/2016/10/'>October 2016</a></li>
	<li><a href='http://geoffboeing.com/2016/09/'>September 2016</a></li>
	<li><a href='http://geoffboeing.com/2016/08/'>August 2016</a></li>
	<li><a href='http://geoffboeing.com/2016/07/'>July 2016</a></li>
	<li><a href='http://geoffboeing.com/2016/06/'>June 2016</a></li>
	<li><a href='http://geoffboeing.com/2016/05/'>May 2016</a></li>
	<li><a href='http://geoffboeing.com/2016/04/'>April 2016</a></li>
	<li><a href='http://geoffboeing.com/2016/03/'>March 2016</a></li>
	<li><a href='http://geoffboeing.com/2016/02/'>February 2016</a></li>
	<li><a href='http://geoffboeing.com/2016/01/'>January 2016</a></li>
	<li><a href='http://geoffboeing.com/2015/12/'>December 2015</a></li>
	<li><a href='http://geoffboeing.com/2015/11/'>November 2015</a></li>
	<li><a href='http://geoffboeing.com/2015/10/'>October 2015</a></li>
	<li><a href='http://geoffboeing.com/2015/09/'>September 2015</a></li>
	<li><a href='http://geoffboeing.com/2015/08/'>August 2015</a></li>
	<li><a href='http://geoffboeing.com/2015/07/'>July 2015</a></li>
	<li><a href='http://geoffboeing.com/2015/06/'>June 2015</a></li>
	<li><a href='http://geoffboeing.com/2015/05/'>May 2015</a></li>
	<li><a href='http://geoffboeing.com/2015/04/'>April 2015</a></li>
	<li><a href='http://geoffboeing.com/2015/03/'>March 2015</a></li>
	<li><a href='http://geoffboeing.com/2015/02/'>February 2015</a></li>
	<li><a href='http://geoffboeing.com/2015/01/'>January 2015</a></li>
	<li><a href='http://geoffboeing.com/2014/12/'>December 2014</a></li>
	<li><a href='http://geoffboeing.com/2014/11/'>November 2014</a></li>
	<li><a href='http://geoffboeing.com/2014/10/'>October 2014</a></li>
	<li><a href='http://geoffboeing.com/2014/09/'>September 2014</a></li>
	<li><a href='http://geoffboeing.com/2014/08/'>August 2014</a></li>
	<li><a href='http://geoffboeing.com/2014/07/'>July 2014</a></li>
	<li><a href='http://geoffboeing.com/2014/06/'>June 2014</a></li>
	<li><a href='http://geoffboeing.com/2014/05/'>May 2014</a></li>
		</ul>
		</aside><aside id="meta-2" class="widget widget_meta"><h2 class="widget-title">Meta</h2>			<ul>
						<li><a rel="nofollow" href="http://geoffboeing.com/wplogin">Log in</a></li>
			<li><a href="http://geoffboeing.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://geoffboeing.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside>			</div><!-- .widget-area -->
		
	</div><!-- .secondary -->

	</div><!-- .sidebar -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
<article id="post-2387" class="post-2387 post type-post status-publish format-standard hentry category-planning tag-boston tag-city tag-complex-systems tag-complexity tag-data tag-data-science tag-design tag-dubai tag-europe tag-geopandas tag-geopy tag-geospatial tag-gis tag-irvine tag-land-use tag-livability tag-maps tag-matplotlib tag-modeling tag-neighborhood tag-networks tag-numpy tag-osaka tag-osmnx tag-pandas tag-portland tag-projection tag-python tag-rome tag-sacramento tag-san-francisco tag-shapely tag-street-network tag-tutorial tag-urban tag-urban-design tag-urban-form tag-urban-planning tag-visualization">
	
	<header class="entry-header">
		<h1 class="entry-title">Square-Mile Street Network Visualization</h1>	</header><!-- .entry-header -->

	<div class="entry-content">
		<p>The heart of Allan Jacobs&#8217; classic book on street-level urban form and design, <em><a href="https://www.pinterest.com/pin/191191946661280803/" onclick="_gaq.push(['_trackEvent', 'outbound-article', 'https://www.pinterest.com/pin/191191946661280803/', 'Great Streets']);" >Great Streets</a></em>, features dozens of hand-drawn figure-ground diagrams in the style of Nolli maps. Each depicts one square mile of a city&#8217;s street network. Drawing these cities at the same scale provides a revealing spatial objectivity in visually comparing their street networks and urban forms.</p>
<p>We can recreate these visualizations automatically with Python and the <a href="http://geoffboeing.com/2016/11/osmnx-python-street-networks/">OSMnx</a> package, which I developed as part of my dissertation. With OSMnx we can download a street network from OpenStreetMap for anywhere in the world in just one line of code. Here are the square-mile diagrams of Portland, San Francisco, Irvine, and Rome created and plotted automatically by OSMnx:</p>
<p><a href="https://i0.wp.com/geoffboeing.com/wp-content/uploads/2016/11/gs_portland_san_francisco_irvine_rome.jpg"><img class="alignnone size-large wp-image-2427" src="https://i0.wp.com/geoffboeing.com/wp-content/uploads/2016/11/gs_portland_san_francisco_irvine_rome.jpg?resize=660%2C697" alt="OSMnx: Figure-ground diagrams of one square mile of Portland, San Francisco, Irvine, and Rome shows the street network, urban form, and urban design in these cities" srcset="https://i0.wp.com/geoffboeing.com/wp-content/uploads/2016/11/gs_portland_san_francisco_irvine_rome.jpg?resize=970%2C1024 970w, https://i0.wp.com/geoffboeing.com/wp-content/uploads/2016/11/gs_portland_san_francisco_irvine_rome.jpg?resize=284%2C300 284w, https://i0.wp.com/geoffboeing.com/wp-content/uploads/2016/11/gs_portland_san_francisco_irvine_rome.jpg?resize=768%2C811 768w, https://i0.wp.com/geoffboeing.com/wp-content/uploads/2016/11/gs_portland_san_francisco_irvine_rome.jpg?w=1000 1000w" sizes="(max-width: 660px) 100vw, 660px" data-recalc-dims="1" /></a></p>
<p><span id="more-2387"></span></p>
<p>The top row depicts the late 19th century orthogonal grids of Portland, Oregon and San Francisco, California. Portland&#8217;s famously compact walkable blocks are clearly visible but its grid is interrupted by the Interstate 405 which tore through the central city in the 1960s. In the bottom row, the business park in suburban Irvine, California demonstrates the coarse-grained, modernist, auto-centric urban form that characterized American urbanization in the latter half of the 20th century. In stark contrast, Rome has a fine-grained, complex, organic form evolved over millennia of self-organization and urban planning.</p>
<p>Remember these are all at the same scale: one square mile. Compare the block sizes and intersection density in Portland to those in Irvine. Compare the orthogonal grid in San Francisco and the modernist simplifications of Irvine to the complex mesh of pedestrian paths, passageways, and alleys comprising much of the circulation network in Rome.</p>
<p><a href="https://i0.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_new_york_paris_tunis_atlanta.jpg"><img class="alignnone size-large wp-image-2436" src="https://i0.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_new_york_paris_tunis_atlanta.jpg?resize=660%2C697" alt="OSMnx: Figure-ground diagrams of one square mile of Manhattan New York, Paris France, Tunis Tunisia, and Atlanta Georgia shows the street network, urban form, and urban design in these cities with Python in the style of Allan Jacobs Great Streets and Nolli maps" srcset="https://i0.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_new_york_paris_tunis_atlanta.jpg?resize=970%2C1024 970w, https://i0.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_new_york_paris_tunis_atlanta.jpg?resize=284%2C300 284w, https://i0.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_new_york_paris_tunis_atlanta.jpg?resize=768%2C811 768w, https://i0.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_new_york_paris_tunis_atlanta.jpg?w=1000 1000w" sizes="(max-width: 660px) 100vw, 660px" data-recalc-dims="1" /></a></p>
<p>Above, we see New York, Paris, Tunis, and Atlanta. Manhattan&#8217;s rectangular grid originates from the New York Commissioners&#8217; Plan of 1811. You can see Broadway weaving diagonally across it. At the center of the Paris square mile lies the Arc de Triomphe, from which Baron Haussmann&#8217;s streets radiate outward, remnants of his massive demolition and renovation of 19th century Paris. At the center of the Tunis square mile lies its Medina, with a complex urban fabric that evolved over the middle ages. Finally, Atlanta is typical of many American downtowns: fairly coarse-grained, disconnected, and surrounded by freeways.</p>
<p>One final example: square miles of central Boston, Jumeirah circle in Dubai, suburban northeastern Sacramento, and Osaka, Japan. What can you tell about these neighborhoods from their street patterns?</p>
<p><a href="https://i1.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_boston_dubai_sacramento_osaka.png"><img class="alignnone size-large wp-image-2437" src="https://i1.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_boston_dubai_sacramento_osaka.png?resize=660%2C697" alt="OSMnx: Figure-ground diagrams of one square mile of Boston Massachusetts, Dubai UAE, Sacramento California, and Osaka Japan shows the street network, urban form, and urban design in these cities with Python in the style of Allan Jacobs Great Streets and Nolli maps" srcset="https://i1.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_boston_dubai_sacramento_osaka.png?resize=970%2C1024 970w, https://i1.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_boston_dubai_sacramento_osaka.png?resize=284%2C300 284w, https://i1.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_boston_dubai_sacramento_osaka.png?resize=768%2C811 768w, https://i1.wp.com/geoffboeing.com/wp-content/uploads/2017/01/gs_boston_dubai_sacramento_osaka.png?w=1000 1000w" sizes="(max-width: 660px) 100vw, 660px" data-recalc-dims="1" /></a></p>
<p>To compare urban form in different kinds of places, these visualizations have depicted some downtowns, some business parks, and some suburban residential neighborhoods. These patterns also vary greatly within cities: Portland&#8217;s suburban east side looks very different than its downtown, and Sacramento&#8217;s grid-like downtown looks very different than its residential suburbs. These visualizations, rather, show us how different urbanization patterns and paradigms compare at the same scale.</p>
<p>Several more examples and all the code to reproduce these diagrams are in <a href="https://github.com/gboeing/osmnx/blob/master/examples/09-example-figure-ground.ipynb" onclick="_gaq.push(['_trackEvent', 'outbound-article', 'https://github.com/gboeing/osmnx/blob/master/examples/09-example-figure-ground.ipynb', 'this notebook']);" >this notebook</a> in OSMnx&#8217;s <a href="https://github.com/gboeing/osmnx" onclick="_gaq.push(['_trackEvent', 'outbound-article', 'https://github.com/gboeing/osmnx', 'GitHub repo']);" >GitHub repo</a>. You can adapt it to visualize any street network anywhere in the world. For more info, check out <a href="http://geoffboeing.com/publications/osmnx-complex-street-networks/">the paper</a> about OSMnx.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-2387" class="share-twitter sd-button share-icon no-text" href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-2387" class="share-facebook sd-button share-icon no-text" href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-2387" class="share-pinterest sd-button share-icon no-text" href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-2387" class="share-linkedin sd-button share-icon no-text" href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-2387" class="share-google-plus-1 sd-button share-icon no-text" href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="whatsapp://send?text=Square-Mile%20Street%20Network%20Visualization http%3A%2F%2Fgeoffboeing.com%2F2017%2F01%2Fsquare-mile-street-network-visualization%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text" href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>	</div><!-- .entry-content -->

	
	<footer class="entry-footer">
		<span class="posted-on"><span class="screen-reader-text">Posted on </span><a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/" rel="bookmark"><time class="entry-date published" datetime="2017-01-02T12:28:02+00:00">January 2, 2017</time><time class="updated" datetime="2017-01-25T09:27:43+00:00">January 25, 2017</time></a></span><span class="byline"><span class="author vcard"><span class="screen-reader-text">Author </span><a class="url fn n" href="http://geoffboeing.com/author/geoff/">gboeing</a></span></span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="http://geoffboeing.com/category/planning/" rel="category tag">Planning</a></span><span class="tags-links"><span class="screen-reader-text">Tags </span><a href="http://geoffboeing.com/tag/boston/" rel="tag">boston</a>, <a href="http://geoffboeing.com/tag/city/" rel="tag">city</a>, <a href="http://geoffboeing.com/tag/complex-systems/" rel="tag">complex systems</a>, <a href="http://geoffboeing.com/tag/complexity/" rel="tag">complexity</a>, <a href="http://geoffboeing.com/tag/data/" rel="tag">data</a>, <a href="http://geoffboeing.com/tag/data-science/" rel="tag">data science</a>, <a href="http://geoffboeing.com/tag/design/" rel="tag">design</a>, <a href="http://geoffboeing.com/tag/dubai/" rel="tag">dubai</a>, <a href="http://geoffboeing.com/tag/europe/" rel="tag">europe</a>, <a href="http://geoffboeing.com/tag/geopandas/" rel="tag">geopandas</a>, <a href="http://geoffboeing.com/tag/geopy/" rel="tag">geopy</a>, <a href="http://geoffboeing.com/tag/geospatial/" rel="tag">geospatial</a>, <a href="http://geoffboeing.com/tag/gis/" rel="tag">gis</a>, <a href="http://geoffboeing.com/tag/irvine/" rel="tag">irvine</a>, <a href="http://geoffboeing.com/tag/land-use/" rel="tag">land use</a>, <a href="http://geoffboeing.com/tag/livability/" rel="tag">livability</a>, <a href="http://geoffboeing.com/tag/maps/" rel="tag">maps</a>, <a href="http://geoffboeing.com/tag/matplotlib/" rel="tag">matplotlib</a>, <a href="http://geoffboeing.com/tag/modeling/" rel="tag">modeling</a>, <a href="http://geoffboeing.com/tag/neighborhood/" rel="tag">neighborhood</a>, <a href="http://geoffboeing.com/tag/networks/" rel="tag">networks</a>, <a href="http://geoffboeing.com/tag/numpy/" rel="tag">numpy</a>, <a href="http://geoffboeing.com/tag/osaka/" rel="tag">osaka</a>, <a href="http://geoffboeing.com/tag/osmnx/" rel="tag">osmnx</a>, <a href="http://geoffboeing.com/tag/pandas/" rel="tag">pandas</a>, <a href="http://geoffboeing.com/tag/portland/" rel="tag">portland</a>, <a href="http://geoffboeing.com/tag/projection/" rel="tag">projection</a>, <a href="http://geoffboeing.com/tag/python/" rel="tag">python</a>, <a href="http://geoffboeing.com/tag/rome/" rel="tag">rome</a>, <a href="http://geoffboeing.com/tag/sacramento/" rel="tag">sacramento</a>, <a href="http://geoffboeing.com/tag/san-francisco/" rel="tag">san francisco</a>, <a href="http://geoffboeing.com/tag/shapely/" rel="tag">shapely</a>, <a href="http://geoffboeing.com/tag/street-network/" rel="tag">street-network</a>, <a href="http://geoffboeing.com/tag/tutorial/" rel="tag">tutorial</a>, <a href="http://geoffboeing.com/tag/urban/" rel="tag">urban</a>, <a href="http://geoffboeing.com/tag/urban-design/" rel="tag">urban design</a>, <a href="http://geoffboeing.com/tag/urban-form/" rel="tag">urban form</a>, <a href="http://geoffboeing.com/tag/urban-planning/" rel="tag">urban planning</a>, <a href="http://geoffboeing.com/tag/visualization/" rel="tag">visualization</a></span>			</footer><!-- .entry-footer -->

</article><!-- #post-## -->

<div id="comments" class="comments-area">

			<h2 class="comments-title">
			17 thoughts on &ldquo;Square-Mile Street Network Visualization&rdquo;		</h2>

		
		<ol class="comment-list">
					<li id="comment-18346" class="pingback even thread-even depth-1">
			<div class="comment-body">
				Pingback: <a href='https://vanurbanism.wordpress.com/2017/01/03/square-mile-street-network-visualization/' rel='external nofollow' class='url'>Square-Mile Street Network Visualization &#8211; Build a Better City</a> 			</div>
</li><!-- #comment-## -->
		<li id="comment-18352" class="comment odd alt thread-odd thread-alt depth-1 parent">
			<article id="div-comment-18352" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://2.gravatar.com/avatar/50167cb6edb02199b2b7ac04000063ca?s=56&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/50167cb6edb02199b2b7ac04000063ca?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn">benschon</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-18352">
							<time datetime="2017-01-03T13:52:02+00:00">
								January 3, 2017 at 13:52							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Is that the densest, oldest part of Irvine? I don&#8217;t know it, but there are parts of that city that look much finer-grained than that. <a href="https://goo.gl/maps/AQmbLeXPcd62" onclick="_gaq.push(['_trackEvent', 'outbound-comment', 'https://goo.gl/maps/AQmbLeXPcd62', 'https://goo.gl/maps/AQmbLeXPcd62']);" rel="nofollow">https://goo.gl/maps/AQmbLeXPcd62</a></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=18352#respond' onclick='return addComment.moveForm( "div-comment-18352", "18352", "respond", "2387" )' aria-label='Reply to benschon'>Reply</a></div>			</article><!-- .comment-body -->
<ol class="children">
		<li id="comment-18539" class="comment byuser comment-author-geoff bypostauthor even depth-2 parent">
			<article id="div-comment-18539" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://1.gravatar.com/avatar/7e0346fd40c7f80320fb01a0d1632de5?s=56&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/7e0346fd40c7f80320fb01a0d1632de5?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn"><a href='http://geoffboeing.com/' rel='external nofollow' class='url'>gboeing</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-18539">
							<time datetime="2017-01-09T12:28:52+00:00">
								January 9, 2017 at 12:28							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>It&#8217;s a business park in the western part of Irvine, near the airport. Most of Irvine comprises the loops-and-lollipops style of suburban form. This Irvine business park is more coarse-grained and more orthogonal, and useful to compare to other types of urban form.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=18539#respond' onclick='return addComment.moveForm( "div-comment-18539", "18539", "respond", "2387" )' aria-label='Reply to gboeing'>Reply</a></div>			</article><!-- .comment-body -->
<ol class="children">
		<li id="comment-19247" class="comment odd alt depth-3 parent">
			<article id="div-comment-19247" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://0.gravatar.com/avatar/6f5e5e12571c7b7a70228892ab68ac4b?s=56&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/6f5e5e12571c7b7a70228892ab68ac4b?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn">Mbai</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-19247">
							<time datetime="2017-01-30T11:39:18+00:00">
								January 30, 2017 at 11:39							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>This is very cool, but don&#8217;t you think controlling for land use is important? How can you compare an industrial development pattern to residential or downtown areas? The Irvine example isn&#8217;t apples to apples.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=19247#respond' onclick='return addComment.moveForm( "div-comment-19247", "19247", "respond", "2387" )' aria-label='Reply to Mbai'>Reply</a></div>			</article><!-- .comment-body -->
<ol class="children">
		<li id="comment-19284" class="comment byuser comment-author-geoff bypostauthor even depth-4">
			<article id="div-comment-19284" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://1.gravatar.com/avatar/7e0346fd40c7f80320fb01a0d1632de5?s=56&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/7e0346fd40c7f80320fb01a0d1632de5?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn"><a href='http://geoffboeing.com/' rel='external nofollow' class='url'>gboeing</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-19284">
							<time datetime="2017-01-31T12:55:20+00:00">
								January 31, 2017 at 12:55							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Hi Marta. Yes indeed, hence my paragraph toward the end of the article: &#8220;To compare urban form in different kinds of places, these visualizations have depicted some downtowns, some business parks, and some suburban residential neighborhoods. These patterns also vary greatly within cities: Portland&#8217;s suburban east side looks very different than its downtown, and Sacramento&#8217;s grid-like downtown looks very different than its residential suburbs. These visualizations, rather, show us how different urbanization patterns and paradigms compare at the same scale.&#8221;</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=19284#respond' onclick='return addComment.moveForm( "div-comment-19284", "19284", "respond", "2387" )' aria-label='Reply to gboeing'>Reply</a></div>			</article><!-- .comment-body -->
</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-18356" class="comment odd alt thread-even depth-1 parent">
			<article id="div-comment-18356" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://1.gravatar.com/avatar/afa23e75dcc30ed69931b3b5eee9dec8?s=56&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/afa23e75dcc30ed69931b3b5eee9dec8?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn">Kate</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-18356">
							<time datetime="2017-01-03T15:20:09+00:00">
								January 3, 2017 at 15:20							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Desperately want you to do Boston&#8217;s North End! Center, say on intersection of Hanover and Prince streets.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=18356#respond' onclick='return addComment.moveForm( "div-comment-18356", "18356", "respond", "2387" )' aria-label='Reply to Kate'>Reply</a></div>			</article><!-- .comment-body -->
<ol class="children">
		<li id="comment-18544" class="comment byuser comment-author-geoff bypostauthor even depth-2">
			<article id="div-comment-18544" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://1.gravatar.com/avatar/7e0346fd40c7f80320fb01a0d1632de5?s=56&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/7e0346fd40c7f80320fb01a0d1632de5?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn"><a href='http://geoffboeing.com/' rel='external nofollow' class='url'>gboeing</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-18544">
							<time datetime="2017-01-09T13:22:29+00:00">
								January 9, 2017 at 13:22							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>I added a new example that includes Boston&#8217;s north end.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=18544#respond' onclick='return addComment.moveForm( "div-comment-18544", "18544", "respond", "2387" )' aria-label='Reply to gboeing'>Reply</a></div>			</article><!-- .comment-body -->
</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-18371" class="comment odd alt thread-odd thread-alt depth-1">
			<article id="div-comment-18371" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://0.gravatar.com/avatar/c1ef0c1c5f57ec8705986fc3a646ac08?s=56&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/c1ef0c1c5f57ec8705986fc3a646ac08?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn"><a href='https://running.flopp.net/' rel='external nofollow' class='url'>Florian</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-18371">
							<time datetime="2017-01-04T06:18:16+00:00">
								January 4, 2017 at 06:18							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Nice work!</p>
<p>Do you think it&#8217;s possible to modify/extend OSMnx such that it works on airport structures instead of street networks (see <a href="http://wiki.openstreetmap.org/wiki/Aeroways" onclick="_gaq.push(['_trackEvent', 'outbound-comment', 'http://wiki.openstreetmap.org/wiki/Aeroways', 'http://wiki.openstreetmap.org/wiki/Aeroways']);" rel="nofollow">http://wiki.openstreetmap.org/wiki/Aeroways</a>)?<br />
One could then automatically create airport posters like these: <a href="https://shop.nomodesign.com/collections/airport-runway-series" onclick="_gaq.push(['_trackEvent', 'outbound-comment', 'https://shop.nomodesign.com/collections/airport-runway-series', 'https://shop.nomodesign.com/collections/airport-runway-series']);" rel="nofollow">https://shop.nomodesign.com/collections/airport-runway-series</a></p>
<p>Regards<br />
Florian</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=18371#respond' onclick='return addComment.moveForm( "div-comment-18371", "18371", "respond", "2387" )' aria-label='Reply to Florian'>Reply</a></div>			</article><!-- .comment-body -->
</li><!-- #comment-## -->
		<li id="comment-18390" class="comment even thread-even depth-1">
			<article id="div-comment-18390" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://0.gravatar.com/avatar/fb1bb491bdbe075c441e74a6bba7a08e?s=56&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/fb1bb491bdbe075c441e74a6bba7a08e?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn"><a href='https://jonathonbelotti.com' rel='external nofollow' class='url'>Jonathon</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-18390">
							<time datetime="2017-01-04T15:54:36+00:00">
								January 4, 2017 at 15:54							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Really nice work mate. I reckon it would have been fun to incorporate coding into your Urban-Planning(?) dissertation.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=18390#respond' onclick='return addComment.moveForm( "div-comment-18390", "18390", "respond", "2387" )' aria-label='Reply to Jonathon'>Reply</a></div>			</article><!-- .comment-body -->
</li><!-- #comment-## -->
		<li id="comment-18447" class="pingback odd alt thread-odd thread-alt depth-1">
			<div class="comment-body">
				Pingback: <a href='http://cityobservatory.org/the-week-observed-jan6_2017/' rel='external nofollow' class='url'>The Week Observed, January 6, 2017 | City Observatory</a> 			</div>
</li><!-- #comment-## -->
		<li id="comment-18448" class="comment even thread-even depth-1 parent">
			<article id="div-comment-18448" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://0.gravatar.com/avatar/697548ba6c88a7f9814c6c8d5ae7d0d6?s=56&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/697548ba6c88a7f9814c6c8d5ae7d0d6?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn"><a href='http://www.sidmitra.com' rel='external nofollow' class='url'>Sid</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-18448">
							<time datetime="2017-01-06T07:05:52+00:00">
								January 6, 2017 at 07:05							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Hi, </p>
<p>    Found this really neat. Took your code and ran it on some cities in Chile: <a href="https://github.com/sidmitra/osmnx_playground/blob/master/01-chile-cities.ipynb" onclick="_gaq.push(['_trackEvent', 'outbound-comment', 'https://github.com/sidmitra/osmnx_playground/blob/master/01-chile-cities.ipynb', 'https://github.com/sidmitra/osmnx_playground/blob/master/01-chile-cities.ipynb']);" rel="nofollow">https://github.com/sidmitra/osmnx_playground/blob/master/01-chile-cities.ipynb</a></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=18448#respond' onclick='return addComment.moveForm( "div-comment-18448", "18448", "respond", "2387" )' aria-label='Reply to Sid'>Reply</a></div>			</article><!-- .comment-body -->
<ol class="children">
		<li id="comment-19136" class="comment odd alt depth-2">
			<article id="div-comment-19136" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://1.gravatar.com/avatar/de4e16d8f22206fe7537b9e97431a3da?s=56&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/de4e16d8f22206fe7537b9e97431a3da?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn">Louis</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-19136">
							<time datetime="2017-01-26T07:37:44+00:00">
								January 26, 2017 at 07:37							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Sid, nice visualizations. The code to set road widths is at the bottom of his notebook linked above. Your visualizations would be easier to read &#8211; esp. Valparaiso. It&#8217;s just one more line of code.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=19136#respond' onclick='return addComment.moveForm( "div-comment-19136", "19136", "respond", "2387" )' aria-label='Reply to Louis'>Reply</a></div>			</article><!-- .comment-body -->
</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-18561" class="comment even thread-odd thread-alt depth-1">
			<article id="div-comment-18561" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://1.gravatar.com/avatar/1e5746ecf77d9b57b0b753b294eefa67?s=56&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/1e5746ecf77d9b57b0b753b294eefa67?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn">Liam</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-18561">
							<time datetime="2017-01-09T20:17:18+00:00">
								January 9, 2017 at 20:17							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Cool!</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=18561#respond' onclick='return addComment.moveForm( "div-comment-18561", "18561", "respond", "2387" )' aria-label='Reply to Liam'>Reply</a></div>			</article><!-- .comment-body -->
</li><!-- #comment-## -->
		<li id="comment-18698" class="pingback odd alt thread-even depth-1">
			<div class="comment-body">
				Pingback: <a href='http://www.weeklyosm.eu/archives/8595' rel='external nofollow' class='url'>weeklyOSM 338 | weekly &#8211; semanario &#8211; hebdo &#8211; săptămânal &#8211; haftalık &#8211; 週刊 &#8211; týdeník &#8211; edisi</a> 			</div>
</li><!-- #comment-## -->
		<li id="comment-18702" class="comment even thread-odd thread-alt depth-1">
			<article id="div-comment-18702" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://2.gravatar.com/avatar/8cd2b389bbae122b0f55e7fbebf5982f?s=56&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/8cd2b389bbae122b0f55e7fbebf5982f?s=112&amp;d=mm&amp;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' />						<b class="fn">Andrew Padgett</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://geoffboeing.com/2017/01/square-mile-street-network-visualization/#comment-18702">
							<time datetime="2017-01-13T12:47:02+00:00">
								January 13, 2017 at 12:47							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Very nice Geoff!</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://geoffboeing.com/2017/01/square-mile-street-network-visualization/?replytocom=18702#respond' onclick='return addComment.moveForm( "div-comment-18702", "18702", "respond", "2387" )' aria-label='Reply to Andrew Padgett'>Reply</a></div>			</article><!-- .comment-body -->
</li><!-- #comment-## -->
		<li id="comment-18992" class="pingback odd alt thread-even depth-1">
			<div class="comment-body">
				Pingback: <a href='http://petras.kudaras.lt/archyvas/2017-01-23/lietuvos-miestu-gatves.html' rel='external nofollow' class='url'>Lietuvos miestų gatvės &#8211; Dar vieno analitiko svetainė</a> 			</div>
</li><!-- #comment-## -->
		<li id="comment-19412" class="pingback even thread-odd thread-alt depth-1">
			<div class="comment-body">
				Pingback: <a href='https://sports.bradstenger.com/newsletters/data-science-newsletter/2017/01/30/data-science-newsletter-january-30-2017/' rel='external nofollow' class='url'>Data Science newsletter &#8211; January 30, 2017 | Sports.BradStenger.com</a> 			</div>
</li><!-- #comment-## -->
		</ol><!-- .comment-list -->

		
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/01/square-mile-street-network-visualization/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://geoffboeing.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='2387' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a68882d6ad" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="131"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- .comments-area -->

	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://geoffboeing.com/2016/12/animating-lorenz-attractor-python/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">Animating the Lorenz Attractor with Python</span></a></div></div>
	</nav>
		</main><!-- .site-main -->
	</div><!-- .content-area -->


	</div><!-- .site-content -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
						<a href="https://wordpress.org/">Proudly powered by WordPress</a>
		</div><!-- .site-info -->
	</footer><!-- .site-footer -->

</div><!-- .site -->

	<div style="display:none">
	<div class="grofile-hash-map-50167cb6edb02199b2b7ac04000063ca">
	</div>
	<div class="grofile-hash-map-7e0346fd40c7f80320fb01a0d1632de5">
	</div>
	<div class="grofile-hash-map-6f5e5e12571c7b7a70228892ab68ac4b">
	</div>
	<div class="grofile-hash-map-afa23e75dcc30ed69931b3b5eee9dec8">
	</div>
	<div class="grofile-hash-map-c1ef0c1c5f57ec8705986fc3a646ac08">
	</div>
	<div class="grofile-hash-map-fb1bb491bdbe075c441e74a6bba7a08e">
	</div>
	<div class="grofile-hash-map-697548ba6c88a7f9814c6c8d5ae7d0d6">
	</div>
	<div class="grofile-hash-map-de4e16d8f22206fe7537b9e97431a3da">
	</div>
	<div class="grofile-hash-map-1e5746ecf77d9b57b0b753b294eefa67">
	</div>
	<div class="grofile-hash-map-8cd2b389bbae122b0f55e7fbebf5982f">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/geoffboeing.com\/2017\/01\/square-mile-street-network-visualization\/":2387};
	</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/01/square-mile-street-network-visualization/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://geoffboeing.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://geoffboeing.com/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<link rel='stylesheet' id='lsi-style-css'  href='http://geoffboeing.com/wp-content/plugins/lightweight-social-icons/css/style-min.css?ver=0.9' type='text/css' media='all' />
<style id='lsi-style-inline-css' type='text/css'>

			.icon-set-lsi_widget-3 a, 
			.icon-set-lsi_widget-3 a:visited, 
			.icon-set-lsi_widget-3 a:focus {
				border-radius: 2px;
				background: #777777 !important;
				color: #FFFFFF !important;
				font-size: 20px !important;
			}
			.icon-set-lsi_widget-3 a:hover {
				background: #659bce !important;
				color: #FFFFFF !important;
			}
</style>
<script type='text/javascript' src='http://geoffboeing.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201706'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://geoffboeing.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://geoffboeing.com/wp-content/themes/twentyfifteen/js/skip-link-focus-fix.js?ver=20141010'></script>
<script type='text/javascript' src='http://geoffboeing.com/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var screenReaderText = {"expand":"<span class=\"screen-reader-text\">expand child menu<\/span>","collapse":"<span class=\"screen-reader-text\">collapse child menu<\/span>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://geoffboeing.com/wp-content/themes/twentyfifteen/js/functions.js?ver=20150330'></script>
<script type='text/javascript' src='http://geoffboeing.com/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://geoffboeing.com/wp-content/plugins/lightweight-social-icons/js/jquery.tooltipster.min.js?ver=0.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://geoffboeing.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.6'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201706.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.6',blog:'9835752',post:'2387',tz:'-8',srv:'geoffboeing.com'} ]);
	_stq.push([ 'clickTrackerInit', '9835752', '2387' ]);
</script>

</body>
</html>
